use strict;
my $str = 'текст текст site.com текст
';
my $regex = qr/\s\S+\.com\s/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";