const regex = new RegExp('(semi colon)|(semi(?!:(\\scolon)))', 'gm')
const str = `here is a semi colon and a semi as an example and here again a semi colon`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);