$re = '/(semi colon)|(semi(?!:(\scolon)))/m';
$str = 'here is a semi colon and a semi as an example and here again a semi colon';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;