import re
regex = re.compile(r"(semi colon)|(semi(?!:(\scolon)))", flags=re.MULTILINE)
test_str = "here is a semi colon and a semi as an example and here again a semi colon"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)