use strict;
my $str = 'here is a semi colon and a semi as an example and here again a semi colon';
my $regex = qr/(semi colon)|(semi(?!:(\scolon)))/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";