package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http\:\/\/)*w*\.*go+gle\s*.\s*com`)
var str = `google.com
http://google.com
http://www.gooogle.com
gooogle . com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}