const regex = /(http\:\/\/)*w*\.*go+gle\s*.\s*com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(http\\:\\\/\\\/)*w*\\.*go+gle\\s*.\\s*com', 'gm')
const str = `google.com
http://google.com
http://www.gooogle.com
gooogle . com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}