$re = '/(http\:\/\/)*w*\.*go+gle\s*.\s*com/m';
$str = 'google.com
http://google.com
http://www.gooogle.com
gooogle . com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);