using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"-?[\d.]+(?:\,\d+)?;{1,2}\s*EUR";
string input = @"-5,84;;EUR
2.764,90;EUR
-47;;EUR";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}