$re = '/-?[\d.]+(?:\,\d+)?;{1,2}\s*EUR/m';
$str = '-5,84;;EUR
2.764,90;EUR
-47;;EUR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);