#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)SUBJECT COMPANY:\s+COMPANY DATA:(?:\s+(?:(?:COMPANY CONFORMED NAME:\s+(?'conformed_name'[^\n]+))|(?:CENTRAL INDEX KEY:\s+(?'CIK'\d{10}))|(?:STANDARD INDUSTRIAL CLASSIFICATION:\s+(?'assigned_SIC'[^\n]+))|(?:IRS NUMBER:\s+?(?'IRS_number'\w{2}-?\w{7,8}))|(?:STATE OF INCORPORATION:\s+(?'state_of_incorporation'\w{2}))|(?:FISCAL YEAR END:\s+(?'fiscal_year_end'(?:0[1-9]|1[0-2])(?:0[1-9]|[1-2][0-9]|3[0-1])))\n))+"
Local $sString = "SUBJECT COMPANY: " & @CRLF & _
"" & @CRLF & _
" COMPANY DATA: " & @CRLF & _
" CENTRAL INDEX KEY: 0000737243" & @CRLF & _
" STANDARD INDUSTRIAL CLASSIFICATION: []" & @CRLF & _
" IRS NUMBER: 592332857" & @CRLF & _
" COMPANY CONFORMED NAME: ACORN VENTURE CAPITAL CORP" & @CRLF & _
" STATE OF INCORPORATION: DE" & @CRLF & _
" FISCAL YEAR END: 1231" & @CRLF & _
"" & @CRLF & _
"<REPORTING-OWNER>" & @CRLF & _
"" & @CRLF & _
"COMPANY DATA: " & @CRLF & _
" COMPANY CONFORMED NAME: HERTZOG CALAMARI & GLEASON" & @CRLF & _
" CENTRAL INDEX KEY: 0000904440" & @CRLF & _
" STANDARD INDUSTRIAL CLASSIFICATION: []" & @CRLF & _
"<RELATIONSHIP>OFFICER"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")