import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "SUBJECT COMPANY:\\s+COMPANY DATA:(?:\\s+(?:(?:COMPANY CONFORMED NAME:\\s+(?'conformed_name'[^\\n]+))|(?:CENTRAL INDEX KEY:\\s+(?'CIK'\\d{10}))|(?:STANDARD INDUSTRIAL CLASSIFICATION:\\s+(?'assigned_SIC'[^\\n]+))|(?:IRS NUMBER:\\s+?(?'IRS_number'\\w{2}-?\\w{7,8}))|(?:STATE OF INCORPORATION:\\s+(?'state_of_incorporation'\\w{2}))|(?:FISCAL YEAR END:\\s+(?'fiscal_year_end'(?:0[1-9]|1[0-2])(?:0[1-9]|[1-2][0-9]|3[0-1])))\\n))+";
final String string = "SUBJECT COMPANY: \n\n"
+ " COMPANY DATA: \n"
+ " CENTRAL INDEX KEY: 0000737243\n"
+ " STANDARD INDUSTRIAL CLASSIFICATION: []\n"
+ " IRS NUMBER: 592332857\n"
+ " COMPANY CONFORMED NAME: ACORN VENTURE CAPITAL CORP\n"
+ " STATE OF INCORPORATION: DE\n"
+ " FISCAL YEAR END: 1231\n\n"
+ "<REPORTING-OWNER>\n\n"
+ "COMPANY DATA: \n"
+ " COMPANY CONFORMED NAME: HERTZOG CALAMARI & GLEASON\n"
+ " CENTRAL INDEX KEY: 0000904440\n"
+ " STANDARD INDUSTRIAL CLASSIFICATION: []\n"
+ "<RELATIONSHIP>OFFICER";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}