use strict;
my $str = 'SUBJECT COMPANY:
COMPANY DATA:
CENTRAL INDEX KEY: 0000737243
STANDARD INDUSTRIAL CLASSIFICATION: []
IRS NUMBER: 592332857
COMPANY CONFORMED NAME: ACORN VENTURE CAPITAL CORP
STATE OF INCORPORATION: DE
FISCAL YEAR END: 1231
<REPORTING-OWNER>
COMPANY DATA:
COMPANY CONFORMED NAME: HERTZOG CALAMARI & GLEASON
CENTRAL INDEX KEY: 0000904440
STANDARD INDUSTRIAL CLASSIFICATION: []
<RELATIONSHIP>OFFICER';
my $regex = qr/SUBJECT COMPANY:\s+COMPANY DATA:(?:\s+(?:(?:COMPANY CONFORMED NAME:\s+(?'conformed_name'[^\n]+))|(?:CENTRAL INDEX KEY:\s+(?'CIK'\d{10}))|(?:STANDARD INDUSTRIAL CLASSIFICATION:\s+(?'assigned_SIC'[^\n]+))|(?:IRS NUMBER:\s+?(?'IRS_number'\w{2}-?\w{7,8}))|(?:STATE OF INCORPORATION:\s+(?'state_of_incorporation'\w{2}))|(?:FISCAL YEAR END:\s+(?'fiscal_year_end'(?:0[1-9]|1[0-2])(?:0[1-9]|[1-2][0-9]|3[0-1])))\n))+/sp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}