re = /SUBJECT COMPANY:\s+COMPANY DATA:(?:\s+(?:(?:COMPANY CONFORMED NAME:\s+(?'conformed_name'[^\n]+))|(?:CENTRAL INDEX KEY:\s+(?'CIK'\d{10}))|(?:STANDARD INDUSTRIAL CLASSIFICATION:\s+(?'assigned_SIC'[^\n]+))|(?:IRS NUMBER:\s+?(?'IRS_number'\w{2}-?\w{7,8}))|(?:STATE OF INCORPORATION:\s+(?'state_of_incorporation'\w{2}))|(?:FISCAL YEAR END:\s+(?'fiscal_year_end'(?:0[1-9]|1[0-2])(?:0[1-9]|[1-2][0-9]|3[0-1])))\n))+/
str = 'SUBJECT COMPANY:
COMPANY DATA:
CENTRAL INDEX KEY: 0000737243
STANDARD INDUSTRIAL CLASSIFICATION: []
IRS NUMBER: 592332857
COMPANY CONFORMED NAME: ACORN VENTURE CAPITAL CORP
STATE OF INCORPORATION: DE
FISCAL YEAR END: 1231
<REPORTING-OWNER>
COMPANY DATA:
COMPANY CONFORMED NAME: HERTZOG CALAMARI & GLEASON
CENTRAL INDEX KEY: 0000904440
STANDARD INDUSTRIAL CLASSIFICATION: []
<RELATIONSHIP>OFFICER'
# Print the match result
str.match(re) do |match|
puts match.to_s
end