#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)data-v-[^\s"]+="[^"]*""
Local $sString = "<div data-v-41dfcbba="" class="aaaaaa" style="width: 100%; height: 100%;"><div data-v-fc1d9bbe="" data-v-41dfcbba="" style="height: 100%;"><div data-v-0392e45a="" data-v-fc1d9bbe="" class="modal upgrade-plan-modal">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")