import Foundation
let pattern = #"data-v-[^\s"]+="[^"]*""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<div data-v-41dfcbba="" class="aaaaaa" style="width: 100%; height: 100%;"><div data-v-fc1d9bbe="" data-v-41dfcbba="" style="height: 100%;"><div data-v-0392e45a="" data-v-fc1d9bbe="" class="modal upgrade-plan-modal">"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)