re = /data-v-[^\s"]+="[^"]*"/m
str = '<div data-v-41dfcbba="" class="aaaaaa" style="width: 100%; height: 100%;"><div data-v-fc1d9bbe="" data-v-41dfcbba="" style="height: 100%;"><div data-v-0392e45a="" data-v-fc1d9bbe="" class="modal upgrade-plan-modal">'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end