import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "data-v-[^\\s\"]+=\"[^\"]*\"";
final String string = "<div data-v-41dfcbba=\"\" class=\"aaaaaa\" style=\"width: 100%; height: 100%;\"><div data-v-fc1d9bbe=\"\" data-v-41dfcbba=\"\" style=\"height: 100%;\"><div data-v-0392e45a=\"\" data-v-fc1d9bbe=\"\" class=\"modal upgrade-plan-modal\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}