using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<command>^\w+)(?<tag>\s[A-Z]:[^ ]*)+";
string input = @"xcopy C:\test D:\target\backup\files C:\aaa D:\target\backup\bbb";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}