$re = '/(?<command>^\w+)(?<tag>\s[A-Z]:[^ ]*)+/m';
$str = 'xcopy C:\\test D:\\target\\backup\\files C:\\aaa D:\\target\\backup\\bbb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);