const regex = /(?<command>^\w+)(?<tag>\s[A-Z]:[^ ]*)+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<command>^\\w+)(?<tag>\\s[A-Z]:[^ ]*)+', 'gm')
const str = `xcopy C:\\test D:\\target\\backup\\files C:\\aaa D:\\target\\backup\\bbb`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}