import re
regex = re.compile(r"(?<command>^\w+)(?<tag>\s[A-Z]:[^ ]*)+", flags=re.MULTILINE)
test_str = "xcopy C:\\test D:\\target\\backup\\files C:\\aaa D:\\target\\backup\\bbb"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")