package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)^(?:https?:\/\/)?([-\w.]+\.[\w]+){1}(\/[\/\d\w\.\-\?\+\&\#\=\~]*)?$`)
var str = `https://www.asd.google.com/search?q=some+text¶m=3#dfsdf`
var substitution = "Domein: $1\nURI: $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}