re = /^(?:https?:\/\/)?([-\w.]+\.[\w]+){1}(\/[\/\d\w\.\-\?\+\&\#\=\~]*)?$/i
str = 'https://www.asd.google.com/search?q=some+text¶m=3#dfsdf'
subst = 'Domein: $1\\nURI: $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result