package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([A-Za-z]{2})(.*?)([A-Za-z][0-9]?)?$`)
var str = `AA123123A1
AA123123A
AA123123123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}