$re = '/^([A-Za-z]{2})(.*?)([A-Za-z][0-9]?)?$/m';
$str = 'AA123123A1
AA123123A
AA123123123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);