re = /^([A-Za-z]{2})(.*?)([A-Za-z][0-9]?)?$/m
str = 'AA123123A1
AA123123A
AA123123123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end