# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ *-.*//g;t' <<< "THIS IS A TEST - 10-01-2010 - HELLO WORLD (OKAY)!!
THIS IS A TEST-10-01-2010 - HELLO WORLD (OKAY)!!
THIS IS A TEST - - - - 10-01-2010 - HELLO WORLD (OKAY)!!
THIS IS A TEST"