import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " *-.*";
final String string = "THIS IS A TEST - 10-01-2010 - HELLO WORLD (OKAY)!!\n"
+ "THIS IS A TEST-10-01-2010 - HELLO WORLD (OKAY)!!\n"
+ "THIS IS A TEST - - - - 10-01-2010 - HELLO WORLD (OKAY)!!\n"
+ "THIS IS A TEST";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}