import re
regex = re.compile(r" *-.*")
test_str = ("THIS IS A TEST - 10-01-2010 - HELLO WORLD (OKAY)!!\n"
"THIS IS A TEST-10-01-2010 - HELLO WORLD (OKAY)!!\n"
"THIS IS A TEST - - - - 10-01-2010 - HELLO WORLD (OKAY)!!\n"
"THIS IS A TEST")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)