#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:[^$\r\n]*\$[^$\r\n]*){2,}$"
Local $sString = "Home$Fruits" & @CRLF & _
"Home$Fruits$Apple" & @CRLF & _
"Home$Fruits$Apple$Red-Apple" & @CRLF & _
"Home$Fruits$Apple$Green-Apple" & @CRLF & _
"Home$Fruits$Banana$Yellow-Banana" & @CRLF & _
"Home$Fruits$Banana$Green-Banana" & @CRLF & _
"Home$Fruits$Orange" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")