package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[^$\r\n]*\$[^$\r\n]*){2,}$`)
var str = `Home$Fruits
Home$Fruits$Apple
Home$Fruits$Apple$Red-Apple
Home$Fruits$Apple$Green-Apple
Home$Fruits$Banana$Yellow-Banana
Home$Fruits$Banana$Green-Banana
Home$Fruits$Orange
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}