const regex = /^(?:[^$\r\n]*\$[^$\r\n]*){2,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[^$\\r\\n]*\\$[^$\\r\\n]*){2,}$', 'gm')
const str = `Home\$Fruits
Home\$Fruits\$Apple
Home\$Fruits\$Apple\$Red-Apple
Home\$Fruits\$Apple\$Green-Apple
Home\$Fruits\$Banana\$Yellow-Banana
Home\$Fruits\$Banana\$Green-Banana
Home\$Fruits\$Orange
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}