re = /^(?:[^$\r\n]*\$[^$\r\n]*){2,}$/m
str = 'Home$Fruits
Home$Fruits$Apple
Home$Fruits$Apple$Red-Apple
Home$Fruits$Apple$Green-Apple
Home$Fruits$Banana$Yellow-Banana
Home$Fruits$Banana$Green-Banana
Home$Fruits$Orange
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end