$re = '/(?s)data.+?run;/m';
$str = 'data xxxxx;
yyyyy
xxxxxx
run;
fffff
yyyyy
data fff;
fffff
run;';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);