using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([\d. ,]+) - - \[(.*?)\] \""(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\"" (\d{1,3})\s(\d{1,}) \""(.*?)\"" \""(.*?)\"" \""(.*?)(\d{20})\""";
string input = @"""147.181.7.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] ""POST /ca/services/GbaOpvragenPersoonProxy-v3_2 HTTP/1.1"" 200 473 ""-"" ""Synapse-PT-HttpComponents-NIO"" ""CN=igj-tst.rijkszaak.nl,OU=Dienst ICT Uitvoering,O=Ministerie van Economische Zaken en Klimaat,L='s-Gravenhage,ST=Zuid-Holland,C=NL,serialNumber=00000004000000149000""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}