import Foundation
let pattern = #"([\d. ,]+) - - \[(.*?)\] \"(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\" (\d{1,3})\s(\d{1,}) \"(.*?)\" \"(.*?)\" \"(.*?)(\d{20})\""#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""147.181.7.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] "POST /ca/services/GbaOpvragenPersoonProxy-v3_2 HTTP/1.1" 200 473 "-" "Synapse-PT-HttpComponents-NIO" "CN=igj-tst.rijkszaak.nl,OU=Dienst ICT Uitvoering,O=Ministerie van Economische Zaken en Klimaat,L='s-Gravenhage,ST=Zuid-Holland,C=NL,serialNumber=00000004000000149000""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)