const regex = /([\d. ,]+) - - \[(.*?)\] \"(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\" (\d{1,3})\s(\d{1,}) \"(.*?)\" \"(.*?)\" \"(.*?)(\d{20})\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\d. ,]+) - - \\[(.*?)\\] \\"(GET|POST|PUT) (.*?)\\s(\\w{4}\\\/\\d.\\d)\\" (\\d{1,3})\\s(\\d{1,}) \\"(.*?)\\" \\"(.*?)\\" \\"(.*?)(\\d{20})\\"', 'gm')
const str = `"147.181.7.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] "POST /ca/services/GbaOpvragenPersoonProxy-v3_2 HTTP/1.1" 200 473 "-" "Synapse-PT-HttpComponents-NIO" "CN=igj-tst.rijkszaak.nl,OU=Dienst ICT Uitvoering,O=Ministerie van Economische Zaken en Klimaat,L='s-Gravenhage,ST=Zuid-Holland,C=NL,serialNumber=00000004000000149000"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}