// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)([\d. ,]+) - - \[(.*?)\] \"(GET|POST|PUT) (.*?)\s(\w{4}\/\d.\d)\" (\d{1,3})\s(\d{1,}) \"(.*?)\" \"(.*?)\" \"(.*?)(\d{20})\""#).unwrap();
let string = "\"147.181.7.11, 10.130.0.49, 10.130.32.73 - - [14/Mar/2019:14:44:54 +0100] \"POST /ca/services/GbaOpvragenPersoonProxy-v3_2 HTTP/1.1\" 200 473 \"-\" \"Synapse-PT-HttpComponents-NIO\" \"CN=igj-tst.rijkszaak.nl,OU=Dienst ICT Uitvoering,O=Ministerie van Economische Zaken en Klimaat,L='s-Gravenhage,ST=Zuid-Holland,C=NL,serialNumber=00000004000000149000\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}