#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?:.+\R){5})"
Local $sString = "Accord.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 3.8.0" & @CRLF & _
" File Version: 3.8.0.6134" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Accord.Video.DirectShow.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 3.8.0" & @CRLF & _
" File Version: 3.8.0.6134" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Accord.Video.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 3.8.0" & @CRLF & _
" File Version: 3.8.0.6134" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Advantech.Adam.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 7.2.0.0" & @CRLF & _
" File Version: 7.2.0.0" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"Advantech.Common.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 7.2.0.0" & @CRLF & _
" File Version: 7.2.0.0" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"Advantech.Protocol.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 7.2.0.0" & @CRLF & _
" File Version: 7.2.0.0" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"Autofac.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 4.8.1" & @CRLF & _
" File Version: 4.8.1.0" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Autofac.Integration.Owin.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 4.2.0-CI-247" & @CRLF & _
" File Version: 4.2.0.247" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Autofac.Integration.SignalR.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 4.0.0-CI-228" & @CRLF & _
" File Version: 4.0.0.228" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Autofac.Integration.WebApi.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 4.0.0-CI-229" & @CRLF & _
" File Version: 4.0.0.229" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Autofac.Integration.WebApi.Owin.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 4.0.0-CI-226" & @CRLF & _
" File Version: 4.0.0.226" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"DirectShowLib-2005.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.1.0.0" & @CRLF & _
" File Version: 2.1.0.0" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"DTKANPR.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 1.3.34" & @CRLF & _
" File Version: 1.3.34" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"DTKRES1.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 1.3.34" & @CRLF & _
" File Version: 1.3.34" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"Dynamitey.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.9.136" & @CRLF & _
" File Version: 2.0.9.136" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"Fasterflect.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.1.3" & @CRLF & _
" File Version: 2.1.3" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"ImpromptuInterface.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 7.0.1" & @CRLF & _
" File Version: 7.0.1.0" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"inpout32.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 1, 5, 0, 0" & @CRLF & _
" File Version: 1, 5, 0, 0" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"inpoutx64.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 1, 5, 0, 0" & @CRLF & _
" File Version: 1, 5, 0, 0" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"JetBrains.Annotations.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2018.2.1" & @CRLF & _
" File Version: 2018.2.1.0" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"log4net.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.8.0-.NET 4.5" & @CRLF & _
" File Version: 2.0.8.0" & @CRLF & _
" Creation Date: 01/29/2019 12:58:20" & @CRLF & _
"" & @CRLF & _
"vjsnativ.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.50727.937" & @CRLF & _
" File Version: 2.0.50727.937 (jsertm.050727-9300)" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"vjssupuilib.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.50727.937" & @CRLF & _
" File Version: 2.0.50727.937 (jsertm.050727-9300)" & @CRLF & _
" Creation Date: 09/03/2018 16:48:42" & @CRLF & _
"" & @CRLF & _
"vjsvwaux.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.50727.937" & @CRLF & _
" File Version: 2.0.50727.937 (jsertm.050727-9300)" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"vjswfc.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.50727.937" & @CRLF & _
" File Version: 2.0.50727.937 (jsertm.050727-9300)" & @CRLF & _
" Creation Date: 09/03/2018 16:48:42" & @CRLF & _
"" & @CRLF & _
"VJSWfcBrowserStubLib.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.50727.937" & @CRLF & _
" File Version: 2.0.50727.937 (jsertm.050727-9300)" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"vjswfccw.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.50727.937" & @CRLF & _
" File Version: 2.0.50727.937 (jsertm.050727-9300)" & @CRLF & _
" Creation Date: 09/03/2018 16:48:40" & @CRLF & _
"" & @CRLF & _
"vjswfchtml.dll" & @CRLF & _
" Directory: C:\Program Files (x86)\TheApp\Hardware" & @CRLF & _
" Product Version: 2.0.50727.937" & @CRLF & _
" File Version: 2.0.50727.937 (jsertm.050727-9300)" & @CRLF & _
" Creation Date: 09/03/2018 16:48:42" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")