import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?:.+\\R){5})";
final String string = "Accord.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 3.8.0\n"
+ " File Version: 3.8.0.6134\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Accord.Video.DirectShow.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 3.8.0\n"
+ " File Version: 3.8.0.6134\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Accord.Video.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 3.8.0\n"
+ " File Version: 3.8.0.6134\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Advantech.Adam.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 7.2.0.0\n"
+ " File Version: 7.2.0.0\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "Advantech.Common.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 7.2.0.0\n"
+ " File Version: 7.2.0.0\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "Advantech.Protocol.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 7.2.0.0\n"
+ " File Version: 7.2.0.0\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "Autofac.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 4.8.1\n"
+ " File Version: 4.8.1.0\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Autofac.Integration.Owin.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 4.2.0-CI-247\n"
+ " File Version: 4.2.0.247\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Autofac.Integration.SignalR.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 4.0.0-CI-228\n"
+ " File Version: 4.0.0.228\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Autofac.Integration.WebApi.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 4.0.0-CI-229\n"
+ " File Version: 4.0.0.229\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Autofac.Integration.WebApi.Owin.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 4.0.0-CI-226\n"
+ " File Version: 4.0.0.226\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "DirectShowLib-2005.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.1.0.0\n"
+ " File Version: 2.1.0.0\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "DTKANPR.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 1.3.34\n"
+ " File Version: 1.3.34\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "DTKRES1.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 1.3.34\n"
+ " File Version: 1.3.34\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "Dynamitey.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.9.136\n"
+ " File Version: 2.0.9.136\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "Fasterflect.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.1.3\n"
+ " File Version: 2.1.3\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "ImpromptuInterface.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 7.0.1\n"
+ " File Version: 7.0.1.0\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "inpout32.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 1, 5, 0, 0\n"
+ " File Version: 1, 5, 0, 0\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "inpoutx64.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 1, 5, 0, 0\n"
+ " File Version: 1, 5, 0, 0\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "JetBrains.Annotations.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2018.2.1\n"
+ " File Version: 2018.2.1.0\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "log4net.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.8.0-.NET 4.5\n"
+ " File Version: 2.0.8.0\n"
+ " Creation Date: 01/29/2019 12:58:20\n\n"
+ "vjsnativ.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.50727.937\n"
+ " File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "vjssupuilib.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.50727.937\n"
+ " File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
+ " Creation Date: 09/03/2018 16:48:42\n\n"
+ "vjsvwaux.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.50727.937\n"
+ " File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "vjswfc.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.50727.937\n"
+ " File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
+ " Creation Date: 09/03/2018 16:48:42\n\n"
+ "VJSWfcBrowserStubLib.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.50727.937\n"
+ " File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "vjswfccw.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.50727.937\n"
+ " File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
+ " Creation Date: 09/03/2018 16:48:40\n\n"
+ "vjswfchtml.dll\n"
+ " Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
+ " Product Version: 2.0.50727.937\n"
+ " File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
+ " Creation Date: 09/03/2018 16:48:42\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}