# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?:.+\R){5})"
test_str = ("Accord.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 3.8.0\n"
" File Version: 3.8.0.6134\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Accord.Video.DirectShow.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 3.8.0\n"
" File Version: 3.8.0.6134\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Accord.Video.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 3.8.0\n"
" File Version: 3.8.0.6134\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Advantech.Adam.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 7.2.0.0\n"
" File Version: 7.2.0.0\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"Advantech.Common.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 7.2.0.0\n"
" File Version: 7.2.0.0\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"Advantech.Protocol.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 7.2.0.0\n"
" File Version: 7.2.0.0\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"Autofac.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 4.8.1\n"
" File Version: 4.8.1.0\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Autofac.Integration.Owin.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 4.2.0-CI-247\n"
" File Version: 4.2.0.247\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Autofac.Integration.SignalR.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 4.0.0-CI-228\n"
" File Version: 4.0.0.228\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Autofac.Integration.WebApi.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 4.0.0-CI-229\n"
" File Version: 4.0.0.229\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Autofac.Integration.WebApi.Owin.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 4.0.0-CI-226\n"
" File Version: 4.0.0.226\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"DirectShowLib-2005.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.1.0.0\n"
" File Version: 2.1.0.0\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"DTKANPR.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 1.3.34\n"
" File Version: 1.3.34\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"DTKRES1.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 1.3.34\n"
" File Version: 1.3.34\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"Dynamitey.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.9.136\n"
" File Version: 2.0.9.136\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"Fasterflect.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.1.3\n"
" File Version: 2.1.3\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"ImpromptuInterface.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 7.0.1\n"
" File Version: 7.0.1.0\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"inpout32.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 1, 5, 0, 0\n"
" File Version: 1, 5, 0, 0\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"inpoutx64.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 1, 5, 0, 0\n"
" File Version: 1, 5, 0, 0\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"JetBrains.Annotations.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2018.2.1\n"
" File Version: 2018.2.1.0\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"log4net.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.8.0-.NET 4.5\n"
" File Version: 2.0.8.0\n"
" Creation Date: 01/29/2019 12:58:20\n\n"
"vjsnativ.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.50727.937\n"
" File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"vjssupuilib.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.50727.937\n"
" File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
" Creation Date: 09/03/2018 16:48:42\n\n"
"vjsvwaux.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.50727.937\n"
" File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"vjswfc.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.50727.937\n"
" File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
" Creation Date: 09/03/2018 16:48:42\n\n"
"VJSWfcBrowserStubLib.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.50727.937\n"
" File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"vjswfccw.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.50727.937\n"
" File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
" Creation Date: 09/03/2018 16:48:40\n\n"
"vjswfchtml.dll\n"
" Directory: C:\\Program Files (x86)\\TheApp\\Hardware\n"
" Product Version: 2.0.50727.937\n"
" File Version: 2.0.50727.937 (jsertm.050727-9300)\n"
" Creation Date: 09/03/2018 16:48:42\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.