// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?:.+\R){5})").unwrap();
let string = "Accord.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 3.8.0
File Version: 3.8.0.6134
Creation Date: 01/29/2019 12:58:20
Accord.Video.DirectShow.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 3.8.0
File Version: 3.8.0.6134
Creation Date: 01/29/2019 12:58:20
Accord.Video.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 3.8.0
File Version: 3.8.0.6134
Creation Date: 01/29/2019 12:58:20
Advantech.Adam.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 7.2.0.0
File Version: 7.2.0.0
Creation Date: 09/03/2018 16:48:40
Advantech.Common.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 7.2.0.0
File Version: 7.2.0.0
Creation Date: 09/03/2018 16:48:40
Advantech.Protocol.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 7.2.0.0
File Version: 7.2.0.0
Creation Date: 09/03/2018 16:48:40
Autofac.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 4.8.1
File Version: 4.8.1.0
Creation Date: 01/29/2019 12:58:20
Autofac.Integration.Owin.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 4.2.0-CI-247
File Version: 4.2.0.247
Creation Date: 01/29/2019 12:58:20
Autofac.Integration.SignalR.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 4.0.0-CI-228
File Version: 4.0.0.228
Creation Date: 01/29/2019 12:58:20
Autofac.Integration.WebApi.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 4.0.0-CI-229
File Version: 4.0.0.229
Creation Date: 01/29/2019 12:58:20
Autofac.Integration.WebApi.Owin.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 4.0.0-CI-226
File Version: 4.0.0.226
Creation Date: 01/29/2019 12:58:20
DirectShowLib-2005.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.1.0.0
File Version: 2.1.0.0
Creation Date: 09/03/2018 16:48:40
DTKANPR.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 1.3.34
File Version: 1.3.34
Creation Date: 09/03/2018 16:48:40
DTKRES1.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 1.3.34
File Version: 1.3.34
Creation Date: 09/03/2018 16:48:40
Dynamitey.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.9.136
File Version: 2.0.9.136
Creation Date: 01/29/2019 12:58:20
Fasterflect.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.1.3
File Version: 2.1.3
Creation Date: 01/29/2019 12:58:20
ImpromptuInterface.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 7.0.1
File Version: 7.0.1.0
Creation Date: 01/29/2019 12:58:20
inpout32.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 1, 5, 0, 0
File Version: 1, 5, 0, 0
Creation Date: 09/03/2018 16:48:40
inpoutx64.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 1, 5, 0, 0
File Version: 1, 5, 0, 0
Creation Date: 09/03/2018 16:48:40
JetBrains.Annotations.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2018.2.1
File Version: 2018.2.1.0
Creation Date: 01/29/2019 12:58:20
log4net.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.8.0-.NET 4.5
File Version: 2.0.8.0
Creation Date: 01/29/2019 12:58:20
vjsnativ.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.50727.937
File Version: 2.0.50727.937 (jsertm.050727-9300)
Creation Date: 09/03/2018 16:48:40
vjssupuilib.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.50727.937
File Version: 2.0.50727.937 (jsertm.050727-9300)
Creation Date: 09/03/2018 16:48:42
vjsvwaux.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.50727.937
File Version: 2.0.50727.937 (jsertm.050727-9300)
Creation Date: 09/03/2018 16:48:40
vjswfc.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.50727.937
File Version: 2.0.50727.937 (jsertm.050727-9300)
Creation Date: 09/03/2018 16:48:42
VJSWfcBrowserStubLib.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.50727.937
File Version: 2.0.50727.937 (jsertm.050727-9300)
Creation Date: 09/03/2018 16:48:40
vjswfccw.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.50727.937
File Version: 2.0.50727.937 (jsertm.050727-9300)
Creation Date: 09/03/2018 16:48:40
vjswfchtml.dll
Directory: C:\\Program Files (x86)\\TheApp\\Hardware
Product Version: 2.0.50727.937
File Version: 2.0.50727.937 (jsertm.050727-9300)
Creation Date: 09/03/2018 16:48:42
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}