#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!(?:---|===)).+$(?!\r?\n(?:---|===))"
Local $sString = "This is a sentence to catch." & @CRLF & _
"" & @CRLF & _
"Title that should not be caught" & @CRLF & _
"-------------------------------" & @CRLF & _
"" & @CRLF & _
"Another sentence to catch." & @CRLF & _
"" & @CRLF & _
"=====================" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"This is another title not to catch, Ha !" & @CRLF & _
"========================================" & @CRLF & _
"" & @CRLF & _
"This is a sentence to catch." & @CRLF & _
"" & @CRLF & _
"Title that should not be caught" & @CRLF & _
"-------------------------------" & @CRLF & _
"" & @CRLF & _
"Another sentence to catch."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")