import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!(?:---|===)).+$(?!\\r?\\n(?:---|===))";
final String string = "This is a sentence to catch.\n\n"
+ "Title that should not be caught\n"
+ "-------------------------------\n\n"
+ "Another sentence to catch.\n\n"
+ "=====================\n\n\n\n"
+ "This is another title not to catch, Ha !\n"
+ "========================================\n\n"
+ "This is a sentence to catch.\n\n"
+ "Title that should not be caught\n"
+ "-------------------------------\n\n"
+ "Another sentence to catch.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}