using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!(?:---|===)).+$(?!\r?\n(?:---|===))";
string input = @"This is a sentence to catch.
Title that should not be caught
-------------------------------
Another sentence to catch.
=====================
This is another title not to catch, Ha !
========================================
This is a sentence to catch.
Title that should not be caught
-------------------------------
Another sentence to catch.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}