re = /^(?!(?:---|===)).+$(?!\r?\n(?:---|===))/m
str = 'This is a sentence to catch.
Title that should not be caught
-------------------------------
Another sentence to catch.
=====================
This is another title not to catch, Ha !
========================================
This is a sentence to catch.
Title that should not be caught
-------------------------------
Another sentence to catch.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end