#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(X...?)\1X|^(...)*XXX|^..X.X.X"
Local $sString = "XXX " & @CRLF & _
" XXX " & @CRLF & _
" XXX" & @CRLF & _
"" & @CRLF & _
"X X X " & @CRLF & _
" X X X " & @CRLF & _
" X X X" & @CRLF & _
"" & @CRLF & _
"X X X" & @CRLF & _
" X X X " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")