const regex = /(X...?)\1X|^(...)*XXX|^..X.X.X/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(X...?)\\1X|^(...)*XXX|^..X.X.X', 'mg')
const str = `XXX
XXX
XXX
X X X
X X X
X X X
X X X
X X X
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}