re = /(X...?)\1X|^(...)*XXX|^..X.X.X/m
str = 'XXX
XXX
XXX
X X X
X X X
X X X
X X X
X X X
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end